Buy Evinrude Outboard Parts

Announcement

Collapse
No announcement yet.

E30 died and won't start

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • E30 died and won't start

    Hey all, I was out in my little skiff with a 6/2011 E30DRSINC. Ran fine going out. Died on way in. Won't start with a no spark condition. I checked main fuse. Has good power through it. I have no voltage at coils when cranking and no indicator lights at emm either. Any ideas? I'd like to fish this weekend if possible. Any direction would be greatly appreciated!

  • #2
    That engine has a TCI type ignition with a start ***it circuit but if the EMM lights are not coming on then check for 12 volts at purple wire to EMM, check ALL GROUNDS, check for 55 VAC(Stator output, start ***it circuit) on white red wire when cranking engine over.
    Regards
    Boats.net
    Evinrude Outboard Parts

    Comment


    • #3
      Originally posted by boats.net View Post
      That engine has a TCI type ignition with a start ***it circuit but if the EMM lights are not coming on then check for 12 volts at purple wire to EMM, check ALL GROUNDS, check for 55 VAC(Stator output, start ***it circuit) on white red wire when cranking engine over.
      No voltage at purple wire. As far as white/red wire, is thst at the emm as well? I don't see that color at stator harness. I see a 2 wire connector at top of flywheel cover and I see one at emm with white/red wire.

      Comment


      • #4
        The 12 volts on purple is with key on, if have no voltage with key on then may have a bad fuse, key switch or wiring between key switch and engine..
        The white/red wire is coming out of EMM, but need to repair purple wire first.
        Regards
        Boats.net
        Evinrude Outboard Parts

        Comment


        • #5
          Originally posted by boats.net View Post
          The 12 volts on purple is with key on, if have no voltage with key on then may have a bad fuse, key switch or wiring between key switch and engine..
          The white/red wire is coming out of EMM, but need to repair purple wire first.
          It's a tiller steer. It doesn't have a key. I checked purple wire while cranking. I can't find the purple wire anywhere but at emm and at duetch connector test harness. There's no purple wire at start button or anywhere else on tiller. I don't know where else to check
          Last edited by StxFishing; 01-12-2019, 12:33 PM.

          Comment


          • #6
            On a tiller model disconnect the black/yellow wire(stop circuit) from EMM and recheck spark. Test system voltage(red/white wire)for 55vac output.
            Regards
            Boats.net
            Evinrude Outboard Parts

            Comment

            Working...
            X